Follow Slashdot blog updates by subscribing to our blog RSS feed

 



Forgot your password?
typodupeerror
DEAL: For $25 - Add A Second Phone Number To Your Smartphone for life! Use promo code SLASHDOT25. Also, Slashdot's Facebook page has a chat bot now. Message it for stories and more. Check out the new SourceForge HTML5 Internet speed test! ×
BSD

Journal goon's Journal: post to misc@openbsd.org - problem 3.2 i386 install 2

Subject: problem 3.2 i386 install
From: peter renshaw
Date: Thu, 23 Oct 2003 22:39 +1000
To: misc@openbsd.org

Hi all,

      I'm having fun installing OpenBsd 3.2 using an official CD [0] to a
low-end i386 [1]. Post installation the machine will not boot. The install
steps I've tried include ...

1. zero out HD/MBR
2. boot via floppy (no problems)
3. fdisk (error reported)
4. disklabel (error reported)
5. install software (error reported)
6. post install (correct error set boot blocks)

      I've installed the 3.2 CD on higher end machines but this
particular machine is a *problem child*. I suspect bios is the problem.
(see hardware description [1]) Does anyone have any suggestions other
than get new HW or installing another os ?

Hardware, fdisk, disklabel, hexified boot & indicated
references, [#] below. This post has been mirrored [2].

Regs PR

P R E I N S T A L L
1. RTFM
-------
*FAQ, 4, 8 and 14 [3].
-4.3.1 ... 4.3.8
-4.10.3
-8.9
-8.19 (yet to try)
-14
*man pages
-disklabel(8)
-fdisk(8)
-boot_i386(8)
-installboot(8)
-biosboot(8)
*cdrom docs
-INSTALL.chs
-INSTALL.i386
*google search
-various combos of keywords [4].

2. confirm HD and CHS
---------------------
*confirm cylinder, head, sector (chs) printed on hard drive (HD)
and on Western Digital (WD) website [5].

I N S T A L L S T E P S
1. zero out HD/MBR
------------------
*zeroed out HD (WD Lifeguard diagnostics, DLGDIAG for dos/win),
[6], [7].
*check supported hardware list [8].

2. boot via floppy (no problems)
--------------------------------
*boot via fd0 using floppy32.fs (CDROM will not boot)
-install method cd0

3. fdisk (error reported)
-------------------------
*select default, "do you want to use all of wd0 [No]"
-intention is to use entire disk for installation but avoid 4.10.3,
pt 2, "No valid boot loader was ever put on the disk".
*fdisk error reported [9].
-"fdisk sysctl (machinedep.bios.diskinfo) device not configured".
*reinit
*quit
*fdisk wd0 yields ...

Disk: wd0 geometry: 989/15/56 [830760 Sectors]
Offset: 0 Signature: 0xAA55
                Starting Ending LBA Info:
  #: id C H S - C H S [ start: size ]
----------------------------------------------------------------------
  0: 00 0 0 0 - 0 0 0 [ 0: 0 ] unused
  1: 00 0 0 0 - 0 0 0 [ 0: 0 ] unused
  2: 00 0 0 0 - 0 0 0 [ 0: 0 ] unused
*3: A6 0 1 1 - 988 14 56 [ 56: 830704 ] OpenBSD

4. disklabel (error reported)
-----------------------------
*intention is very simple install first with 2 partitions, 1 root and
the other swap disk [10].
*disklabel reports error, "cant get disk bios device not configured".
*delete any existing partitions, leaving c.
*add "a" wd0a 800000 sectors [11].
*add "b" wd0b leftover sectors.
*quit saving change.
*disklabel wd0 yeilds ...

# /dev/rwd0c:
type: ESDI
disk: ESDI/IDE disk
label: WDC AC2420H
flags:
bytes/sector: 512
sectors/track: 56
tracks/cylinder: 15
sectors/cylinder: 840
cylinders: 989
total sectors: 830760
rpm: 3600
interleave: 1
trackskew: 0
cylinderskew: 0
headswitch: 0 # microseconds
track-to-track seek: 0 # microseconds
drivedata: 0

16 partitions:
# size offset fstype [fsize bsize cpg]
    a: 800000 56 4.2BSD 1024 8192 16 # (Cyl. 0*- 952*)
    b: 30704 800056 swap # (Cyl. 952*- 988)
    c: 830760 0 unused 0 0 # (Cyl. 0 - 988)

5. install software (error reported)
------------------------------------
*set hostname.
*do not config network (yet).
*set passwd
*install from cd0 sans x-server [12].
-[X] bsd
-[X] base32.tgz
-[X] etc32.tgz
-[X] misc32.tgz
-[X] comp32.tgz
-[X] man32.tgz
*set timezone
*make device nodes
*creating boot block displays following error [13].
-"unable to get BIOS geometry must specify -h -s"

6. post install (correct error, set boot blocks, uncertainty on path)
---------------------------------------------------------------------
*failure requires following from '14.8 - Installing Bootblocks'.

# cd /mnt/usr/mdec
# cp boot /mnt/boot
# ./installboot -v -h15 -s56 /mnt/boot biosboot wd0

*is this right? I see many references [14] to
something like ...

# cp boot /boot
# /usr/mdec/installboot -v -h15 -s56 /boot /usr/mdec/biosboot wd0

*halt
*reboot

6. reboot (error reported)
--------------------------
*machine boots, following ...

Using drive 0 partition 3
reading boot ...
probing: pc0 com0 com1 mem[640k 15M a20=on]
disk: fd0
>> OpenBSD/i386 BOOT 1.29
Open(hd0a:/etc/boot.conf)
Cant read disklabel

*I interact ...
boot> machine diskinfo
Disk Bios# Type Cyls Heads Secs Flags Checksum
fd0 0x0 *none* 80 2 18 0x4 0x0

*and again
boot> machine boot hd0a
failed to read disk label

*hexify bootblock [15]

dmesg:
------
OpenBSD 3.2 (RAMDISK) #97: Thu Oct 3 20:06:10 MDT 2002
      deraadt@i386.openbsd.org:/usr/src/sys/arch/i386/compile/RAMDISK
cpu0: Intel 486DX4 ("GenuineIntel" 486-class)
cpu0: FPU,V86
real mem = 16367616 (15984K)
avail mem = 11632640 (11360K)
using 225 buffers containing 921600 bytes (900K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(fd) BIOS, date 04/18/94
pcibios at bios0 function 0x1a not configured
bios0: ROM list: 0xc0000/0x8000 0xc8000/0x4000
isa0 at mainbus0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard
vga0 at isa0 port 0x3b0/48 iomem 0xa0000/131072
wsdisplay0 at vga0: console (80x25, vt100 emulation), using wskbd0
wdc0 at isa0 port 0x1f0/8 irq 14
wd0 at wdc0 channel 0 drive 0:
wd0: 16-sector PIO, CHS, 405MB, 989 cyl, 15 head, 56 sec, 830760
      sectors
atapiscsi0 at wdc0 channel 0 drive 1
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: SCSI0 5/cdrom
      removable
wd0(wdc0:0:0): using BIOS timings
cd0(wdc0:0:1): using BIOS timings
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask 4040 netmask 4040 ttymask 4042
rd0: fixed, 3560 blocks
root on rd0a
rootdev=0x1100 rrootdev=0x2f00 rawdev=0x2f02

fdisk:
------
Disk: wd0 geometry: 989/15/56 [830760 Sectors]
Offset: 0 Signature: 0xAA55
                Starting Ending LBA Info:
#: id C H S - C H S [ start: size ]
----------------------------------------------------------------------
0: 00 0 0 0 - 0 0 0 [ 0: 0 ] unused
1: 00 0 0 0 - 0 0 0 [ 0: 0 ] unused
2: 00 0 0 0 - 0 0 0 [ 0: 0 ] unused
*3: A6 0 1 1 - 988 14 56 [ 56: 830704 ] OpenBSD

disklabel
---------
# /dev/rwd0c:
type: ESDI
disk: ESDI/IDE disk
label: WDC AC2420H
flags:
bytes/sector: 512
sectors/track: 56
tracks/cylinder: 15
sectors/cylinder: 840
cylinders: 989
total sectors: 830760
rpm: 3600
interleave: 1
trackskew: 0
cylinderskew: 0
headswitch: 0 # microseconds
track-to-track seek: 0 # microseconds
drivedata: 0

16 partitions:
# size offset fstype [fsize bsize cpg]
    a: 800000 56 4.2BSD 1024 8192 16 # (Cyl. 0*- 952*)
    b: 30704 800056 swap # (Cyl. 952*- 988)
    c: 830760 0 unused 0 0 # (Cyl. 0 - 988)

hexified bootblock
------------------
can be viewed at misc.openbsd.

notes:
======
[0] http://www.lsl.com.au/
[1] hardware:
      cpu 486DX4
      ram 16Mb
      board VL/I-486SV2GX4
      bios 04/18/94 SIS-85C471-I486SVG00 Award V4.05G
      hd WDC A2C420H
      chs 989/15/56

[2] mirrored at http://slashdot.org/~goon/journal and
      http://www.netspace.net.au/~goonmail and
http://marc.theaimsgroup.com/?l=openbsd-misc

[3] ftp://ftp.openbsd.org/pub/OpenBSD/doc/obsd-faq.txt
[4] google searchs include ...
      *machinedep.bios.diskinfo
      *cant get disk bios device not configured
      *openbsd 3.2 i386 install
      *SIS-85C471 openbsd i386 install
      *VL/I-486SV2GX4 openbsd i386 install

[5] http://www.wdc.com
[6] http://support.wdc.com/download/index.asp#windlg
[7] also used "dd if=/dev/zero of=/wd0 bs=512 count=1"
[8] INSTALL.i386 on 3.2 cdrom
[9] fdisk sysctl (machinedep.bios.diskinfo) device not configured.
[10] build PPPo gateway with firewall,
      http://www.realo.ca/BSDinstall.html recommends using
      simple setup with root and swap only.

[11] wd0a assign arbitrary 800000 sectors (391 Mb) to "/"
      on final setup "/" will be == 373 Mb, wd0b swap == 32 Mb.
      this is a naive setup for swap. The following post suggests that
      "16Mb ram swapping in a *gateway/firewall system* is not likely"...
      http://groups.google.com.au/groups?hl=en&lr=&ie=UTF-8&oe=UTF-8&th=3c43002ab8d1d43e&rnum=17

[12] comp32.tgz will b removed later for security reasons.
[13] this is covered in '4.10.3 - My i386 won't boot after install',
      and 14.8 - Installing Bootblocks - i386 specific.

[14] installboot(8) and install faq, 4.8 - Installing Bootblocks - i386
        specific.

      # cd /usr/mdec; ./installboot /boot biosboot sd0
      # cd /usr/mdec; ./installboot -h -s /boot biosboot sd0

[15] copy bootblock to disk and hexify using Vim and *hexman* by
        Peter.Franz, http://vim.sourceforge.net/scripts/

      # mount -t msdos /dev/fd0a /mnt/mnt/
      # dd if=/dev/rwd0c of=/mnt/mnt/wd0label bs=512 count=2

"$Id: problem_description,v 1.9 2003/10/23 12:22:45 sah Exp $"

This discussion has been archived. No new comments can be posted.

post to misc@openbsd.org - problem 3.2 i386 install

Comments Filter:
  • marco says RTFM http://www.openbsd.org/faq/faq4.html#SmallRAM [openbsd.org]

    reading the above I reckon I should ...

    at step 5 after I install, must set swapon(8) [openbsd.org] *before* continuing ...

    manually invoke swap disk post install sets
    *envoke shell
    */mnt/sbin/swapon /dev/wd0b
    *exit
    *then continue
  • notes:
    ======
    [0] http://www.lsl.com.au/ search for openbsd
    [1] hardware:
    cpu 486DX4
    ram 16Mb
    board VL/I-486SV2GX4
    bios 04/18/94 SIS-85C471-I486SVG00 Award V4.05G
    hd WDC A2C420H
    chs 989/15/56

    [2] mirrored at http://slashdot.org/~goon/journal and
    http://www.netspace.net.au/~goonmail

    [3] ftp://ftp.openbsd.org/pub/OpenBSD/doc/obsd-faq.tx t
    [4] google searchs include ...
    *machinedep.bios.diskinfo
    *cant get disk bios device not configured
    *op

"The following is not for the weak of heart or Fundamentalists." -- Dave Barry

Working...