He's asking the question because the pattern occurs a few times, and he fears that it may look bad with long variable names.
Given that, I think the current top answer (by user coredump) is a good suggestion, since it prevents duplicate code by using a function. So it basically says his code is good enough, just encapsulate it in a function (although the function name was a poor choice in my opinion).
Also, I think the answer you refer to (I believe it's the one by user Doc Brown) is a good suggestion, although it may not be the best in that particular case. But what if all of a sudden the pattern is repeated but with more possibilities (like 4, 5 and 6 variables)? You'd need a more generic function, and this particular answer provides a step in that direction (although again I think the function and variables names were poor choices - probably because it was just an example). And he even says at the end of the answer: if you don't need a generic approach for more variables, your code is fine, and maybe you can use coredump's approach.
Of course, my opinions reflect my thoughts about coding, mainly these: avoid duplicate code like the plague, and make some (or a lot of) effort creating the best function names possible (even though "best" is highly subjective in this case).