Average Ratings 0 Ratings

Total
ease
features
design
support

No User Reviews. Be the first to provide a review:

Write a Review

Average Ratings 0 Ratings

Total
ease
features
design
support

No User Reviews. Be the first to provide a review:

Write a Review

Description

Typically, a WebSocket will be utilized to create a connection, offering a streamlined communication pathway between the server and the client. You can feel confident knowing that if a WebSocket connection cannot be established, the system will revert to HTTP long-polling as a backup option. Furthermore, should the connection fail, the client will make automatic attempts to reconnect seamlessly. This allows for easy scaling across multiple servers while efficiently broadcasting events to all connected clients. Socket.IO is a powerful library designed to facilitate low-latency, bidirectional, and event-driven communication between clients and servers. This library is built upon the WebSocket protocol and enhances it by offering features such as fallback to HTTP long-polling and built-in reconnection capabilities. The WebSocket protocol itself enables a full-duplex, low-latency communication link between the server and web browsers. There are multiple Socket.IO server implementations available, along with client versions in most widely-used programming languages, ensuring broad compatibility and flexibility for developers. This versatility allows developers to easily integrate real-time functionalities into their applications.

Description

TekSIP for Windows is a SIP Registrar as well as a SIP Proxy. TekSIP supports UDP (IPv4 & IPv6), TCP (IPv4 & IPv6), TLS, and WebSocket transports. Only commercial editions support Secure WebSocket and TLS. TekSIP has been tested on Microsoft Windows Vista and Windows 7/8/10/11 servers. TekSIP is a signaling service for WebRTC based SIP-based phones. TekSIP is compliant with RFC 3261 and RFC 3263. It also complies to RFC 3581, RFC 3891, RFC 3311 and RFC 3481. It supports NAT traversal, ENUM. Please refer to Readme for technical details on NAT traversal. You can choose the IP address that will be listened to and alternative SIP endpoints when making outgoing calls. You can also log the session details in a log and monitor registrations and active sessions in real-time. Windows Performance Monitor (Perfmon.exe) allows you to monitor the number of active sessions and registrations. TekSIP redirects calls to an alternate endpoint if the called endpoint is not available (Offline, busy ...). GUI can be used to terminate an active SIP session.

API Access

Has API Yes 

API Access

Has API Yes 

Screenshots View All

Screenshots View All

Integrations

Aspecto Yes 
Azure Marketplace Yes 
Hoppscotch Yes 
Sails Yes 
TekRADIUS No 
Tennis API Yes 

Integrations

Aspecto No 
Azure Marketplace No 
Hoppscotch No 
Sails No 
TekRADIUS Yes 
Tennis API No 

Pricing Details

No price information available.
Free Trial No 
Free Version No 

Pricing Details

$239
Freeware version allows maximum 3 SIP endpoints registration and 3 simultaneous SIP sessions. Enterprise edition allows upto 100 simultaneous registration and SIP sessions. Following features are not supported in free edition;

Enterprise
* SDP Manipulation
* TLS Transport
* SMPP Gateway

SP
* Enterprise features
* External Authenticator
* SRTP -> RTP interworking
* WebRTC Media Gateway
* Unlimited number of simultaneous SIP registrations and sessions
* Route incoming calls to registered extensions
* IPv6 support
* RADIUS AAA
Free Trial Yes 
Free Version Yes 

Deployment

Web-Based Yes 
On-Premises No 
iPhone App No 
iPad App No 
Android App No 
Windows No 
Mac No 
Linux No 
Chromebook No 

Deployment

Web-Based No 
On-Premises Yes 
iPhone App No 
iPad App No 
Android App No 
Windows Yes 
Mac No 
Linux No 
Chromebook No 

Customer Support

Business Hours No 
Live Rep (24/7) No 
Online Support Yes 

Customer Support

Business Hours Yes 
Live Rep (24/7) Yes 
Online Support Yes 

Types of Training

Training Docs Yes 
Webinars No 
Live Training (Online) No 
In Person No 

Types of Training

Training Docs Yes 
Webinars No 
Live Training (Online) Yes 
In Person No 

Vendor Details

Company Name

Socket.IO

Website

socket.io

Vendor Details

Company Name

KaplanSoft

Founded

2011

Country

Turkey

Website

www.kaplansoft.com

Product Features

Product Features

Telephony

Auto-Dialer No 
Call Center Management No 
Call Monitoring Yes 
Contact Management No 
IVR / Voice Recognition No 
Inbound Reporting No 
Outbound Reporting No 
Predictive Dialer No 
Telemarketing Management No 
VoIP Yes 
Voice & Data Integration Yes 

Alternatives

ejabberd Reviews

ejabberd

ProcessOne

Alternatives

TekIVR Reviews

TekIVR

KaplanSoft