After three days of watching them argue I finally resolved the issue by dropping a few convenience methods and replacing the class with a NamedTuple.
Ah, the namedtuple, love that type, makes small property bags simple and efficient, and yet you still go nuts and sub-class it if you really have to
Looking at my user-site directory, apparently write my own Properties class - actually, three different classes for some reason, all slightly different and way more complicated than the namedtuple
My only niggle is the declaration syntax with the redundant type name
Point = namedtuple("Point", "x y")
which just looks ripe for danger lol.