Slashdot is powered by your submissions, so send in your scoop

 



Forgot your password?
typodupeerror
Check out the new SourceForge HTML5 internet speed test! No Flash necessary and runs on all devices. ×
User Journal

Journal stoolpigeon's Journal: Solution to Amarok crashing my system 1

I mentioned earlier I think that I'm back to successfully using my Nvidia card with proprietary drivers - but for one issue. If I started Amarok (which would start - loaded to the tray) and then try to restore the gui to the desktop, my system would completely lock up. No keyboard input would be accepted at all. I had to hard power it down and restart.

Being the middle aged genius that I am - I started amarok from the command line and piped the error output to a file. That gave me something to google and took me to https://bugs.kde.org/show_bug.cgi?id=323635 which gave me the solution.

As soon as I saw OpenGL was involved I knew this would make me happy. I can't get my system config to switch the compositing type away from XRender. Trying to check the OpenGL settings for the card throws an error - so it's some kind of driver problem I'm sure.

I just had to follow the directions there and disable the analyzer in Amarok in the file they mention. I don't know what the analyzer is or what it does - but things seem just fine without it so I'm cool. Though I like Clementine which I was using instead as it had no problems. So I exported my playlists from Amarok to something I could open in Clementine and I may just make the jump.

Either way - kind of cool, what search can do.

This discussion has been archived. No new comments can be posted.

Solution to Amarok crashing my system

Comments Filter:

For every problem there is one solution which is simple, neat, and wrong. -- H. L. Mencken

Working...