Forgot your password?
typodupeerror

Comment: Re:So let me get this straight... (Score 5, Informative) 213

by kawika (#42915085) Attached to: WebKit As Broken As Older IE Versions?

I'm the author.

So let ME get this straight: I get paid nothing for my work on jQuery, where we clean up behind all the major browsers so that people don't need to wait months or years for bugs to be fixed. We also report these bugs to the appropriate vendors with clear test cases; as you can imagine we get our share of crappy bug reports and don't want to do that to these guys. You would also like me to donate more time to become an expert at Webkit to the point where I can fix these bugs immediately on their side, despite the fact that several major well-funded companies (Google, Apple, BlackBerry, and now Opera) are paying people to (NOT) fix these bugs. Sorry, but one unpaid volunteer open-source job is enough for me.

I would love for all the WebKit contributors to get together and say, "We'll show that guy! HAHA we fixed all your bugs so THERE!" There are rumors, however, that Opera is laying off 200 engineers and I seriously doubt they'll keep a large staff of people on fixing WebKit bugs. I've emailed Peter Kasting privately and think he is sincere in trying to get some of these fixed though.

Comment: Microsoft has some valid points there (Score 1) 913

by kawika (#42707901) Attached to: Microsoft Blames PC Makers For Windows Failure

Whatever the problems of Windows itself, the fact is that PC hardware makers haven't done a very good job of producing attractive and functional systems. I am in a situation where I have to run Windows and I want some non-Apple hardware. What systems out there aren't consumer-grade crap? Perhaps the Thinkpad Carbon X1 is nice for example, but I ordered one in early December and have yet to receive it due to "quality control problems" according to Lenovo.

Comment: Conditionally include 1.9/2.0 (Score 1) 250

by kawika (#40643105) Attached to: jQuery 2.0 Will Drop Support For IE 6, 7, 8

True, Walmart.com will have IE 6/7/8 visitors for years to come, but there are plenty of places where someone might be using jQuery but not need IE 6/7/8 support. It could be a cutting-edge public web site, a desktop app using an embedded HTML rendering engine, or a mobile app where oldIE doesn't matter. You can either use jQuery 1.9 for now, or use graceful degradation to give those people a really basic experience and a nudge to upgrade.

Comment: Re:IE Version Code Breakdown? (Score 4, Informative) 250

by kawika (#40642757) Attached to: jQuery 2.0 Will Drop Support For IE 6, 7, 8

As far as bugs and quirks go, a lot of the ones in IE6 and IE7 are also present in IE8. In specific, things like eating HTML5 tags, the lack of true opacity support and the proprietary IE event model that used attachEvent instead of addEventListener. There's quite a bit of code in jQuery to deal with IE event issues, for example the lack of a bubbling change event. IE8 managed to plug some memory leaks and wasn't as bizarre with the "attroperties" issue as IE7 was, but they still have a lot of sins in common.

13. ... r-q1

Working...