Forgot your password?
typodupeerror
Security

jawtheshark's Journal: LuxTrust on Ubuntu 12.04 LTS 3

Journal by jawtheshark

Intro: I was complaining on social networks that the LuxTrust hardware tokens are forced upon all teachers in my country. That's a huge problem because I got my mother in law on Linux and this thing is very very badly supported. Officially the website say "Ubuntu 10.04" supported. Funnily enough, their website also doesn't mention Windows 8 as supported. Anyway, they're a useless company in my eyes... I wish them the most ill possible.

Here is my little test run:

So, I decided to test the LuxTrust support under Ubuntu GNU/Linux 12.04 LTS i686[1]. I installed a virtual machine from the ISO, and from that blank slate, I wanted to try how "easy" this is. Well, there you go, I downloaded their "middleware".

The good news: Ubuntu Software center presented it as installable and it installed it without apparently problems after clicking the Install. Good! If this were enough, I'd say "it's supported"[2]. Let's test it. So, I go to CCP-Connect, one of the few banks known to work well with LuxTrust under Linux. The thing needs Java[3], and I as expected, and I don't have it installed. I get redirected, at once to http://www.oracle.com/java. The sheer number of options is intimidating. If I weren't very familiar with Java, I wouldn't have a clue what to select. Now, this might be P&T Luxembourg doing it wrong, but the site you should send end-users to is http://www.java.com/. Never send an end-user to a developer site, it's a horrible mistake.

Anyway, I do what is needed and surprise[4], there is no Oracle Java for Ubuntu. A RPM and a tar.gz. Now, if I weren't who I am, I would be blocked again. So, I download the tar.gz and I'll be honest to you, dropped right to the command line, tar zxvf later to /opt, and doing an update-alternatives --install of the new java, oh, and while we're at it, make a symlink for the plugin [5]. Now, of course, I understand it's Oracle whom I have a problem with, but I bet that you won't get this documentation at LuxTrust and they sure as hell can't walk you though this. Of course, the way I did this, I'm now responsible for updating my Java. Of course, there is a PPA, but can I trust that? (I'll have to, if I want automatic updates, but you get the point, no?)

Now, going back to the banking site, it seems to run. I get to the point where I have to select their product and then a screen saying there is no signing stick. (Obviously, I don't have one.)

For kicks 'n giggles, I tried OpenJDK/JRE with the icedtea plugin. No surprise, but that doesn't work: gray pane instead of the applet, but other java applets works fine. So, Oracle Java mandatory. Heck, even Minecraft runs op OpenJDK for crying out loud!

At least their middleware didn't install some kind of daemon, which I what I would have expected with something called "Middleware".
Funny also: The Oracle Java VM warns you from running applets all the time, even the test applet on the java.com site. Scary. Well, not to me, but to a normal end user.

[1] i686 for a good reason, from what I read getting it to run is significantly harder on amd64.
[2] I knew that it wasn't going to work
[3] Wait, isn't that what dependencies are for... Naaaah, dependencies. Who uses that?
[4] Not really, I've been here before
[5] Probably better use update-alternatives for that one too!

This discussion has been archived. No new comments can be posted.

LuxTrust on Ubuntu 12.04 LTS

Comments Filter:
  • Seems like the LuxTrust system is doing the bare minimum to meet their contractual obligations. To be honest, I wouldn't support Win8 either, but your complaints about their java issues are completely legitimate. Not to mention native x86_64 support becoming something I am increasingly shocked to see being ignored. Maybe it's just the tech in me, but I've seen the mistake of failure to adopt new platforms before. It gets ugly. Techs calling around to find out if anyone still has a laptop with a serial

    • It is probably the tech in you. Why do you think I kick and yell and scream about this. The tech in me revolts over incompetence and technical bad choices. Look, I understand the needs of three factor authentication, and it's all fine and dandy, until you start to enumerate the downsides. They want to implement this at the level of a small country and it's even hard to get through in a mid-size company with standardized IT.

      What I can tell you, is that it is clearly some ministers pet project. He has b

      • I agree with your frustrations wholeheartedly. This does indeed smack of a politician's pet project.

Administration: An ingenious abstraction in politics, designed to receive the kicks and cuffs due to the premier or president. -- Ambrose Bierce

Working...