Please create an account to participate in the Slashdot moderation system

 



Forgot your password?
typodupeerror
Apple

Submission + - iTunes upgrade forces users to buy new OSX (guardian.co.uk) 1

NoAkai writes: "The Guardian writes this about newer iDevices not being supported on older versions of OSX: "[...]I connected the shuffle to our computer, but a message came up saying the iPod "cannot be used because it requires iTunes version 10.0 or later". So I downloaded iTunes 10, but then another message popped up: "Open Failed This package type requires Mac OS X 10.5." It was the same story with the iPhone 4.""

Slashdot Top Deals

If it happens once, it's a bug. If it happens twice, it's a feature. If it happens more than twice, it's a design philosophy.

Working...